javascript – Uncaught TypeError: a.indexOf is not a function error when opening new foundation project

javascript – Uncaught TypeError: a.indexOf is not a function error when opening new foundation project

This error might be caused by the jQuery event-aliases like .load(), .unload() or .error() that all are deprecated since jQuery 1.8. Lookup for these aliases in your code and replace them with the .on() method instead. For example, replace the following deprecated excerpt:

$(window).load(function(){...});

with the following:

$(window).on(load, function(){ ...});

Please add below jQuery Migrate Plugin

<script src=https://code.jquery.com/jquery-3.3.1.min.js></script>
<script src=https://code.jquery.com/jquery-migrate-1.4.1.min.js></script>

javascript – Uncaught TypeError: a.indexOf is not a function error when opening new foundation project

This error is often caused by incompatible jQuery versions. I encountered the same error with a foundation 6 repository. My repository was using jQuery 3, but foundation requires an earlier version. I then changed it and it worked.

If you look at the version of jQuery required by the foundation 5 dependencies it states jquery: ~2.1.0.

Can you confirm that you are loading the correct version of jQuery?

I hope this helps.

Leave a Reply

Your email address will not be published.