intellij idea – Error:(3, 26) java: package javafx.application does not exist

intellij idea – Error:(3, 26) java: package javafx.application does not exist

The JavaFX package is not included in JDK 9 and later. You need to install JDK 8, or you can add the JavaFX package separately, for example, from JDK 8 (jfxrt.jar).

Try this solution in IDEA press ctrl+shift+alt+s (File -> Project Structure) then select Project -> Project Language Level and select 8 or above.

intellij idea – Error:(3, 26) java: package javafx.application does not exist

If you are java 8+ the javafx libs are not included. you need to add them via your favorite build tool as a compile runtime lib.

Leave a Reply

Your email address will not be published.